Upgrading from CentOS-5.9 ( or any older CentOS-5 release ):
If you are already running CentOS-5.9 or an older CentOS-5 release, all you need to do is update your machine via yum by running :
‘yum update’
Running ‘yum list updates’ before doing the update is recommended, so you can get a list of packages that are going to be updated. To check you are indeed on CentOS-5.10, run : ‘rpm -q centos-release’ and that should return: ‘centos-release-5-10.el5.centos.1’
If you are running CentOS-5.9 and have the CR repo enabled, a simple ‘yum update’ will still move your machine to 5.10. But since the CR repo already contained all the 5.10 updates, there will only be a handful of rpms that need to be installed for the 5.9 to 5.10 upgrade. If you are not running the CR repo, we highly encourage everyone to install and run this repository on their machines. More details on the CR repo can be found online at http://wiki.centos.org/AdditionalResources/Repositories/CR
で、今回起こったエラーと言うのは下記の様なもの。
Error Downloading Packages: 1:mod_ssl-2.2.3-83.el5.centos.x86_64: failure: RPMS/mod_ssl-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try. httpd-manual-2.2.3-83.el5.centos.x86_64: failure: RPMS/httpd-manual-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try. httpd-2.2.3-83.el5.centos.x86_64: failure: RPMS/httpd-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try. tzdata-2013g-1.el5.x86_64: failure: RPMS/tzdata-2013g-1.el5.x86_64.rpm from cr: [Errno 256] No more mirrors to try.
ちなみに、全体は下記の様な感じ。
# yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* rpmforge: ftp.kddilabs.jp
* updates: ftp.iij.ad.jp
116 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package centos-release.x86_64 10:5-10.el5.centos set to be updated
---> Package centos-release-notes.x86_64 0:5.10-0 set to be updated
---> Package httpd.x86_64 0:2.2.3-83.el5.centos set to be updated
---> Package httpd-manual.x86_64 0:2.2.3-83.el5.centos set to be updated
---> Package mod_ssl.x86_64 1:2.2.3-83.el5.centos set to be updated
---> Package tzdata.x86_64 0:2013g-1.el5 set to be updated
--> Finished Dependency Resolution
Dependencies Resolved
=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
centos-release x86_64 10:5-10.el5.centos base 21 k
centos-release-notes x86_64 5.10-0 base 40 k
httpd x86_64 2.2.3-83.el5.centos cr 1.3 M
httpd-manual x86_64 2.2.3-83.el5.centos cr 819 k
mod_ssl x86_64 1:2.2.3-83.el5.centos cr 98 k
tzdata x86_64 2013g-1.el5 cr 797 k
Transaction Summary
=============================================================================
Install 0 Package(s)
Upgrade 6 Package(s)
Total size: 3.0 M
Total download size: 2.9 M
Is this ok [y/N]: y
Downloading Packages:
[Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error Downloading Packages:
1:mod_ssl-2.2.3-83.el5.centos.x86_64: failure: RPMS/mod_ssl-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try.
httpd-manual-2.2.3-83.el5.centos.x86_64: failure: RPMS/httpd-manual-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try.
httpd-2.2.3-83.el5.centos.x86_64: failure: RPMS/httpd-2.2.3-83.el5.centos.x86_64.rpm from cr: [Errno 256] No more mirrors to try.
tzdata-2013g-1.el5.x86_64: failure: RPMS/tzdata-2013g-1.el5.x86_64.rpm from cr: [Errno 256] No more mirrors to try.
コメント